查看完整版本: [-- exchange2010 DAG 服务器间无法自动切换--求助 --]

Exchange技术论坛 -> Exchange Server 2010 -> exchange2010 DAG 服务器间无法自动切换--求助 [打印本页] 登录 -> 注册 -> 回复主题 -> 发表主题

dong8126 2018-04-03 09:41

exchange2010 DAG 服务器间无法自动切换--求助


各位大神:
     请帮忙给分析一下哪里出现了问题!
之前有两台exchange2010 做了DAG配置分别是ex01  ex02 ,其中一台老旧ex01的服务器磁盘空间不足无法同步邮件数据库了,故重新配置一台ex03 ,在配置完ex03之后,把EX01退出了高可用性组,同时把ex03加到了高可用性组,并同步了数据库,新配置了证书并启用了;DAG中的见证配置中也更新了EX03‘;在DNS中也指定了MX指针,但是在测试时把ex02断网发现,DAG无法自动切换到EX03上边 ,客户端打开outlook总是提示用户名及密码。  其中更改见证服务器文件目录时提示 dag 这台机器的状态为failed [attachment=3488]   还请大神们帮忙分析一下哪里可能有问题?

dong8126 2018-04-03 09:47
截图内容为:
无法使用文件共享见证资源“ \DAG"联机,当前的状态为”FAILED“

flowerwaiter 2018-04-04 20:49
dong8126:截图内容为:
无法使用文件共享见证资源“ \DAG"联机,当前的状态为”FAILED“?(2018-04-03 09:47)?

在创建DAG最初我们需要在AD中创建一个禁用的计算机账户(CNO),然后给所有成员服务器对于这个CNO完全控制的权限,你检查下新加的这个节点有加到ACL里面么?

dong8126 2018-04-09 08:08
原来建 的时候我记得给加过,我再确认一下,抽早上时间再测一下,多谢版本,如还有问题我再接着请教。

dong8126 2018-04-10 07:38
今天一早测试了一下DAG切换,按版主之前的指教查看了DAG主机的权限 ,确实没有加上相关权限,可能之前手贱给点上重置了。在服务器集群中 可以查看到ex01 和 ex03的切换,但是切换到ex03之后,客户端无法连接到邮箱服务器,总是要求提供用户名密码,就算是提供了也无法连接,感觉是不是证书配置错误了?? 把原来的ex01连上网络之后,过一会客户端就正常了。

dong8126 2018-04-10 16:28
今天一早测试了一下DAG切换,按版主之前的指教查看了DAG主机的权限 ,确实没有加上相关权限,可能之前手贱给点上重置了。在服务器集群中 可以查看到ex02和 ex03的切换,但是切换到ex03之后,客户端无法连接到邮箱服务器,总是要求提供用户名密码,就算是提供了也无法连接,感觉是不是证书配置错误了?? 把原来的ex02连上网络之后,过一会客户端就正常了。

flowerwaiter 2018-04-10 20:33
dong8126:今天一早测试了一下DAG切换,按版主之前的指教查看了DAG主机的权限 ,确实没有加上相关权限,可能之前手贱给点上重置了。在服务器集群中 可以查看到ex02和 ex03的切换,但是切换到ex03之后,客 ..?(2018-04-10 16:28)?

这个应该是证书问题,就是DC颁发给EX01的证书没有包含ex02的名字,你需要将EX01和EX02的证书SAN统一,一般会使用你在AD中创建的CNO名字。

dong8126 2018-04-11 07:44
版主,你说的 证书San统一 有些不太明白,还请能仔细的说明一下!
下边是理解做的截图,请版主看看是不应当这样做:

[attachment=3504][attachment=3505][attachment=3506][attachment=3507]

dong8126 2018-04-11 07:45
其中 .cn 是公网域名,  .ad 是内部自建域名。

flowerwaiter 2018-04-12 01:30
dong8126:其中 .cn 是公网域名,??.ad 是内部自建域名。?(2018-04-11 07:45)?

autodiscover发布的是哪个地址?

dong8126 2018-04-12 07:14
autodiscover发布的是 DAG的IPV4地址

dong8126 2018-04-12 17:29
autodisover 对应的是DAG的ip地址 ( 内网的)。

dong8126 2018-04-12 17:30
autodiscover 对应的DAG主机的内网IP地址

dong8126 2018-04-12 17:31
以为网站上没有发布上去,所以重复发了好几次,不好意思!

flowerwaiter 2018-04-12 23:24
dong8126:以为网站上没有发布上去,所以重复发了好几次,不好意思!?(2018-04-12 17:31)?

ok,你把两个服务器的URL统一一下
https://mp.weixin.qq.com/s?__biz=MzA3NTkxMTE1OA==&tempkey=OTUyX2x4TFN6MGNrRUtDSWZJL0h3WnhOWGNSSVpURDB4Q0xfYmRCNmZPRHZjREdIbXpuNFliRDBCWW40bF9tVzEzMjN3UnFuVHI0ZU5RV2FEbXlYdjNJVVhrTjFhYS1tU2pWdHhYNHB1NmtfbzJ4RkRfMV9IY01iUWctclpmT1N1dWlUMkF1eER4VUpLMEM4T19DWHA0eXZ0M01CWWdnaXRYUnZmYy1TZkF%2Bfg%3D%3D&chksm=0770deb6300757a0404296258477009e78014ca91c8856410fa40b6c4651546a04f5b7f0cc0a#rd

dong8126 2018-04-18 07:55
版主,不好意思,有事几天,回来查看您给的链接已失效,麻烦再给一下!!

dong8126 2018-04-19 08:37
今天一早把证书重新配置了,断开ex02 客户端重新打开outlook 还是提示要用户名及密码,输入用户名及密码无效。
1.在EX02网络断网的情况下,把客户端 outlook配置文件删除,重配手动指定EX03 死活不指不上去,就是默认EX02。
2.把EX02网络连通,在客户端 重新全新配置outlook客户端,手动指定ex03 服务器,可是一检查 自动就变成了ex02了

这是为何呢?

dong8126 2018-04-23 08:00
今天一早把证书重新配置了,断开ex02 客户端重新打开outlook 还是提示要用户名及密码,输入用户名及密码无效。
1.在EX02网络断网的情况下,把客户端 outlook配置文件删除,重配手动指定EX03 死活不指不上去,就是默认EX02。
2.把EX02网络连通,在客户端 重新全新配置outlook客户端,手动指定ex03 服务器,可是一检查 自动就变成了ex02了



这个问题已解决,是EX03上边的 信息管理IIS 中 站点中的身份验证没有开启。  不清楚为何需要手动打开,在EMC中这些地方是打开的。


查看完整版本: [-- exchange2010 DAG 服务器间无法自动切换--求助 --] [-- top --]



Powered by phpwind v8.7.1 Code ©2003-2011 phpwind
Time 0.015529 second(s),query:6 Gzip enabled